Login

Willkommen, Gast

Passwort vergessen?

Verfasste Forenbeiträge

Ansicht von 15 Beiträgen - 1 bis 15 (von insgesamt 19)
  • Autor
    Beiträge
  • als Antwort auf: Wo finde ich den Basisformularsatz zum Download ? #9567

    Steffen
    Teilnehmer
    als Antwort auf: Problem mit Subreport – DT JasperReport #8484

    Steffen
    Teilnehmer

    Hallo,
    wie ich auf den super Fotos erkennen konnte, haben Sub Report und SubSub_Report den gleichen Parameternamen. Bitte verschiedene Namen vergeben.

    Der Parameter des SubSub_reports muss ebenfalls dem Haubtreport bekannt sein.

    als Antwort auf: Firmendaten #8422

    Steffen
    Teilnehmer

    Hallo,

    im Ordner extensions/server befindet sich ein Bundle.jar, dort existiert ein Property Absender. Dieses Bundle dient der Mehrsprachigkeit der Formulare.Die Properties aus diesem Bundle sind erkennbar an einem $R{….} im Formular-template

    Steffen

    als Antwort auf: Formulare im Basistemplate #8244

    Steffen
    Teilnehmer

    Funktionieren die Formulare nach dem erneutem Speichern?
    Gibt es noch Fehlermeldungen?

    Oder geht es grundsätzlich um den Umstand, dass die Formulare erneut gespeichert werden müssen?
    Wenn ja muss ein Bug eingestellt werden.
    Die Formulare werden beim Anlegen vom Jaspercompiler in Form einer .jasper compiliert werden in der Tabelle t_ud_report output unter blreportcls abgelegt.
    Bitte mal nachschauen ob vor dem erneuten Speichern dort etwas existiert.

    Steffen

    als Antwort auf: iReport Schriftart hinzufügen funktioniert nicht #7786

    Steffen
    Teilnehmer

    Hallo Thomas,

    der Wiki-Artikel ist in der Tat etwas verwirrend. Ich werde ihn überarbeiten! Danke für den Hinweis.
    Die verwendeten Fonts müssen zuerst unter Extras/Option/Font/
    hinzugefügt werden(TTF-Dateien)
    Danach am besten iReport neu starten!
    Im selben Fenster, existiert der Button „Export as extension“, also Font auswählen und Button betätigen, danach einen Datei-Namen angeben .jar(wichtig).
    Diese generierte JAR wird nun dem Clathpath unter Extras/Option/Clathpath Button Add JAR hinzugefügt.

    Der Name der Schriftart müsste jetzt im XML-Modus korrekt eingetragen werden.

    Steffen

    als Antwort auf: iReport startet nicht #7778

    Steffen
    Teilnehmer

    Hallo Thomas,

    1.Mit welcher Version iReport wurde das Formular erstellt?
    2.Wird Scriptlet oder Bundle verwendet. Wenn Ja sind die Nuclos-Parameter gesetzt?
    3.befindet sich die jasperreports-3.5.3.jar im webapp/WEB-INF/lib Verzeichnis?
    4.Könntest Du die Jrxml anhängen? Ein Blick in das Template wäre hilfreich.

    Gruß Steffen

    als Antwort auf: BasisTemplatePlus – Drucken #7699

    Steffen
    Teilnehmer

    Hallo,

    es muss sich im Installationspfad folgende Ordnerstruktur befinden: extensions/server. Im Seververzeichnis müssen folgende Jar-Archive enthalten sein Bundle.jar, core.jar, javase.jar, QRCode_1.jar.
    Sollten die Dateien nicht vorhanden sein, muss nach dem Hinzufügen der Installer erneut ausgeführt werden oder die Dateien werden zusätzlich in das Verzeichnis webapp/WEB-INF/lib kopiert, dann ist ledeglich ein Serverneustart erforderlich.

    Gruß Steffen

    als Antwort auf: Word Formular #7551

    Steffen
    Teilnehmer

    sorry, ich konnte den Fehler jetzt auch nachstellen 4.0.9
    OK

    als Antwort auf: Word Formular #7544

    Steffen
    Teilnehmer

    Den Fehler gab es in den Versionen 4.0/ 4.1 vor den 10.02.2014

    als Antwort auf: Exception beim Einbinden eines Fonts in PDF #7248

    Steffen
    Teilnehmer

    Hallo Kreutho,

    verwendest Du das Styled- Propertie bzw. verwendest Du Bold oder Italic für Deine Schriftzeichen und sind für diese Schriftzeichen dann auch entsprechende Vorlagen dem Jasper bekannt?(TTF-Bold, TTF-Italic).

    Hätte ich das Jrxml oder die Font.xml könnte ich mir ein besseres Bild machen. Vielleicht kannst Du es hier hochladen.? Am besten auch die Schriftarten.

    Steffen

    als Antwort auf: Exception beim Einbinden eines Fonts in PDF #7238

    Steffen
    Teilnehmer

    Hallo,

    es sieht mehr danach aus als wenn dort ein Fehler in der JRXML existiert. Aber um genaueres zu sagen, müsste ich ein Blick hinein werfen.

    Steffen

    als Antwort auf: Formular Error: inconvertible types #6798

    Steffen
    Teilnehmer

    Hallo mdoerr,

    ich denke da hilft nur ein Blick ins Serverlog.
    Vermutung:
    die Barcode4J benötigt noch eine Abhängigkeit.

    als Antwort auf: Formular Error: inconvertible types #6797

    Steffen
    Teilnehmer

    Hallo,

    ja den Fehler konnte ich bei Versionsänderung nachstellen, allerdings erst nach dem erneuten Laden des Formulars im Designer.
    [i]Ebenfalls trat der Fehler mal nach der Editierung und Speicherung in der XML-Ansicht auf.
    (Konnte ich aber gerade nicht nachstelllen)[/i]

    Korrektur zum Barcode:
    Die Barcode.jar müssen nicht gesigned werden. Da Jasperreports serverseitig ausgeführt wird reicht es aus die Jars in „extensions/server“ abzulegen und nicht „extensions/common“ .Das Signen wird nur klientseitig benötigt.
    Dieser Sachverhalt gilt im übrigen für alle Extensions die Jasperreport betreffen (QrCode, Scriptlets, Fontextensions)
    Wenn man nicht jedesmal neuinstallieren möchte reicht es wenn die Jars in „webapp/WEB-INF/lib“ abgelegt werden. Nach einem Neustart des Servers stehen die Funktionalitäten zur Verfügung.

    als Antwort auf: Logo in Formular einbinden #6776

    Steffen
    Teilnehmer

    Hallo Thorsten,

    aus der Palette wählst Du die Image-Komponente und ziehst sie an die Stelle Deiner Wahl.
    Im folgenden Dialog „Select an immage……“ suchst Du Dein Image. Stelle den Filter (unten) auf alle Dateien dann siehst Du auch PNG. OK->fertig.
    Das property „scale Image“ setzt Du auf „retain Shape“ bei Image Expression müsste der Pfad zur Datei stehen und Expression class müsste String sein.

    Das selbe Image musst du jetzt im Nuclos hochladen. Konfiguration->sonstige->Ressource.
    Wichtig ist das es der selbe Dateinamen ist. Dann sollte es funktionieren.

    Steffen

    als Antwort auf: Parameter „Datasource Expression“ erzeugt Fehler #6770

    Steffen
    Teilnehmer

    Hallo Stefan,

    bitte überprüfe wo Du das Expression :“((org.nuclos.server.report.api.JRNuclosDataSource)$P{REPORT_DATA_SOURCE}).getDataSource(„…….“) eingetragen hast.

    Ich erhalte Deinen Fehler,wenn ich es anstatt bei Use a datasource Expression bei use a connection expression eintrage.
    Also bei den Subreport-Properties im iReport Designer prüfen ob Datasource Expression gewählt ist.

Ansicht von 15 Beiträgen - 1 bis 15 (von insgesamt 19)